关于PuTTY密钥恢复漏洞(CVE-2024-31497)的预警提示

发布时间:2024-05-16浏览次数:10

一、漏洞详情

PuTTY是一种流行的开源终端仿真器、串行控制台和网络文件传输应用程序,支持SSHTelnetSCPSFTP等协议,可使用该软件通过SSH远程访问和管理服务器和其他网络设备。

近日,监测到PuTTY中存在一个密钥恢复漏洞(CVE-2024-31497)。PuTTY版本0.68 - 0.80中使用NIST P521曲线的ECDSA私钥生成签名的代码中存在漏洞(当使用PuTTYPageantSSH服务器进行身份验证时,它会根据密钥生成签名),获得约60条签名消息和公钥的威胁者可能恢复用户的NIST P-521私钥,然后伪造签名,登录使用该密钥的任何服务器,导致信息泄露和未授权访问SSH服务器等。

建议受影响用户做好资产自查以及预防工作,以免遭受黑客攻击。

二、影响范围

PuTTY版本 0.68 - 0.80

注:以下(不一定完整)产品列表捆绑了受影响的PuTTY版本:

FileZilla 3.24.1 - 3.66.5

WinSCP 5.9.5 - 6.3.2

TortoiseGit 2.4.0.2 - 2.15.0

TortoiseSVN 1.10.0 - 1.14.6

三、修复建议

目前该漏洞已经修复,受影响用户可升级到以下版本:

PuTTY 0.81

FileZilla 3.67.0

WinSCP 6.3.3

TortoiseGit 2.15.0.1