关于Parse Server注入漏洞(CVE-2024-29027)的预警提示

发布时间:2024-03-26浏览次数:23

一、漏洞详情

Parse Server是一款基于node.js的开源框架。

近日,监测到Parse Server中修复了一个注入漏洞(CVE-2024-29027)。Parse Server版本6.5.57.0.0-alpha.29之前,由于缺乏对Cloud Function名称和 Cloud Job名称的字符串清理,当调用无效的Parse Server Cloud Function名称或Cloud Job名称时可能导致服务器崩溃,或可能导致代码注入或远程代码执行等。

建议受影响用户做好资产自查以及预防工作,以免遭受黑客攻击。

二、影响范围

Parse Server版本< 6.5.5

7.0.0-alpha.1<= Parse Server版本< 7.0.0-alpha.29

三、修复建议

目前该漏洞已经修复,受影响用户可升级到Parse Server版本6.5.57.0.0-alpha.29及更高版本。